Partial Telstra inbound failure
Incident Report for YourCloudTelco
Resolved
Inbound Calls from telstra are now successfully routing to our network. No explanation for this fault has been provided.
Posted Oct 17, 2017 - 16:48 AEDT
Identified
We have received reports that Inbound calling from specified locations within the Telstra network are failing to reach our service.

It appears the failure is within the Telstra network. We will advise when we receive updates.
Posted Oct 17, 2017 - 15:13 AEDT