Issues with Call Queue feature
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 26, 2019 - 15:05 AEST
Identified
We have identified an issue with the Call Queue feature, our team is currently working on getting this resolved ASAP.
Posted 3 months ago. Jul 26, 2019 - 14:59 AEST
This incident affected: YourCloudTelco Calling Platform (Network).