Connecting calls
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 12:31 AEDT
Investigating
We have identified an issues with calls connecting, both inbound and outbound calls are being affected.
Posted Jan 31, 2020 - 12:22 AEDT
This incident affected: YourCloudTelco Calling Platform (Network).