Inbound Calling Delay
Incident Report for YourCloudTelco
Resolved
This issue is now resolved. Please let us know if you see any problems going forward.
Posted 3 months ago. Apr 15, 2019 - 10:56 AEST
Investigating
We are experiencing a delay in connection of some inbound calls and some calls are timing out. Our team is investigating this and we will provide updates.
Posted 3 months ago. Apr 15, 2019 - 10:06 AEST
This incident affected: YourCloudTelco Calling Platform (Network).