Service Disruption
Incident Report for YourCloudTelco
Resolved
This incident has now been resolved.
Posted 2 months ago. Jul 10, 2019 - 16:00 AEST
Update
We are continuing to investigate this issue.
Posted 2 months ago. Jul 10, 2019 - 15:59 AEST
Investigating
We have reports of call failures and device registration dropouts. We are investigating this as a matter of urgency.

This is not affecting all customers and regions.
Posted 2 months ago. Jul 10, 2019 - 15:44 AEST
This incident affected: YourCloudTelco Calling Platform (Network).