Registration status
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 11:15 AEST
Identified
The registration indicator in Arena is currently not working. Registration information can still be found in Trace.
Posted 2 months ago. Jul 10, 2019 - 13:56 AEST
This incident affected: Arena.