Inbound call issues
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted Dec 27, 2019 - 07:01 AEDT
Investigating
We are investigating an issue with inbound calls.
Posted Dec 27, 2019 - 06:55 AEDT
This incident affected: YourCloudTelco Calling Platform (Network).