Switchboard
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 10:14 AEST
Monitoring
As part of this upgrade a security token controlling
Posted Sep 07, 2023 - 01:59 AEST
Identified
Yesterday evening, our development team implemented a new user security feature that inadvertently restricted customer access to the Switch Board numbers portal. We have identified the source of the issue and are actively working to restore full access.

Network calling capabilities have not been affected.
Posted Sep 06, 2023 - 10:13 AEST
This incident affected: YourCloudPBX.