Call Quality Issues
Incident Report for YourCloudTelco
Resolved
The issue is resolved and our team is completing a review.
Posted Nov 30, 2017 - 15:44 AEDT
Investigating
We are investigating call quality issues that are being experienced on our network currently. Bear with us, and know that our team is doing everything we can to get this resolved urgently.
Posted Nov 30, 2017 - 15:22 AEDT