Faxing
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 06:19 AEST
Investigating
We are currently investigating an issue with our fax server.
Posted Jun 28, 2022 - 16:31 AEST
This incident affected: YourCloudTelco Calling Platform (Network).