Access to CloudPBX Temporarily Suspended
Incident Report for YourCloudTelco
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 11:28 AEST
Investigating
Access to CloudPBX has been temporarily suspended, and international calling will be unavailable until further notice. All other calling services are unaffected and will continue to operate as usual. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Apr 28, 2024 - 08:32 AEST
This incident affected: YourCloudTelco Calling Platform (Network), Arena, YourCloudTelco Management CAP, and YourCloudPBX.