Customer balances incorrect: Billing Anniversary 12 of month
Incident Report for YourCloudTelco
Resolved
This has been resolved and all invoices have been regenerated.
Will will monitor this over the next few days.
Posted 2 months ago. May 09, 2019 - 18:29 AEST
Identified
Customers with a bill anniversary of 12th of the month may see incorrect account balances as these have been carried forward from April into this month. Our billing team is working on this resolving this now.

You may need to apply a temporary credit limit to your customer accounts whilst make the update.
Posted 3 months ago. May 07, 2019 - 15:49 AEST
This incident affected: YourCloudTelco Management CAP and YourCloudPBX.